Linux-如何升级php的版本

2024-06-13 144 0

1.初始环境

操作系统:opencloundos

php版本:php-7.2.4

2.下载php的最新安装包,可以去官网,或者其他提供下载的网站,这里我下载的是php-8.2.3版本

3.进入到压缩包所在目录,进行解压缩

tar -xvf php-8.2.3

4.生成makefile文件

cd php-8.2.3

./configure --prefix=/usr/local/php-8.2.3 --with-config-file-path=/usr/local/php-8.2.3/etc   --with-zlib-dir --with-freetype --enable-mbstring --enable-soap --enable-calendar --with-curl --with-zlib --enable-gd --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --with-zip --with-pdo-mysql --with-mysqli --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-jpeg --with-openssl --with-fpm-user=www --with-fpm-group=www --with-libdir=/lib/x86_64-linux-gnu --enable-ftp  --with-kerberos --with-gettext --with-xmlrpc --with-xsl --enable-opcache --enable-intl --with-pear --enable-fpm

5.安装

make && make install

可能出现的错误:

make:*** [ext/fileinfo/libmagic/apprentice.lo] Error 1

可用运行内存不足,关闭一些服务保持1g以上即可。

6.安装完成之后配置软连接,这里以我的配置为例

cd /usr/bin/
# 可查看下原来的执行文件,可先进行备份再操作
ll php*
# 备份,删除原来的文件
ln -s /usr/local/php-8.3.1/bin/php
ln -s /usr/local/php-8.3.1/sbin/php-fpm php-fpm
ln -s /usr/local/php-8.3.1/bin/phpize phpize

7.配置完成之后查看php的版本

php -v

8.复制配置文件

cd /usr/local/php-8.3.1/etc/
cp php-fpm.conf.default php-fpm.conf
cd /usr/local/php-8.3.1/etc/php-fpm.d/
cp www.conf.default www.conf

9.复制服务文件,启动php-fpm。

cp /root/php-8.2.3/sapi/fpm/php-fpm.service /etc/systemd/system/php-fpm.service
systemctl start php-fpm.service

如果提示9000端口被占用,可先结束原来的php-fpm服务,再重新启动服务

lsof -i:9000
kill pid
systemctl restart php-fpm.service

相关文章

Linux-使用 ACME 申请证书并自动续期
【转】如何升级linux的libstdc++.so
Linux-配置service服务
Linux-常用操作
Linux-apache部署多个.net项目
Linux-使用Consul

发布评论